Estigmatizados

La informática profesional no es un juego de políticos

Matriz de compatibilidad JSF / Java Enterprise Edition

Aprovechando este periodo de vacaciones, intentaré retomar el trabajo en el blog.

En este primer artículo, que en principio tenía pensado llamar “JSF 1.2 y Tomcat 6: ¡Vaya infierno!”, quiero definir una matriz de compatibilidad entre las versiones de Java Enterprise y servidores de aplicaciones. Para muchos será algo obvio, pero yo siempre tengo que bucear en la documentación para buscar las cosas.

JSF JSR Java JSP JSTL Servlet Tomcat GlassFish
JSF 1.1 JSR 127 J2SE 1.3 JSP 1.2 JSTL 1.0 Servlet 2.3 4.1.x
5.5.x
 
JSF 1.2 JSR 252 Java SE 5 JSP 2.1 JSTL 1.2 Servlet 2.5 6.0.x v2.x
JSF 2.0 JSR 314 Java SE 5
Java SE 6
JSP 2.1
JSP 2.2
JSTL 1.2 Servlet 2.5
Servlet 3.0
6.0.x v2.x
v3.x

 JSF 1.2 RI: Mojarra JSF 1.2_12

JSF 2.0 RI: Morraja JSF 2.0.2

Java EE JSR Servlet/JSP Tomcat GlassFish
Java EE 6
(Java SE 6)
JSR 315 3.0/2.2   v3.x
Java EE 5
(Java SE 5)
JSR 154 2.5/2.1 6.0.x v2.x
J2EE 1.4
(J2SE 1.3)
  2.4/2.0 5.5.x  
J2EE 1.3
(J2SE 1.2)
JSR 53 2.3/1.2 4.1.x
(archivada)
 
J2EE 1.2
(J2SE 1.2)
N/A 2.2/1.1 3.3.x
(archivada)
 

diciembre 29, 2009 - Posted by | Tecnología

Aún no hay comentarios.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: